GHSA-3j6g-hxx5-3q26

Observable Discrepancy in Apache Kafka

En bref

Publiée
Mise à jour
CVE
CVE-2021-38153
Alias
BIT-kafka-2021-38153
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Paquets affectés

PaquetVersions
Maven · org.apache.kafka:kafka_2.11introduced 2.0.0, last affected 2.4.1
Maven · org.apache.kafka:kafka_2.12introduced 2.0.0, fixed 2.6.3
Maven · org.apache.kafka:kafka_2.12introduced 2.7.0, fixed 2.7.2
Maven · org.apache.kafka:kafka_2.12introduced 2.8.0, fixed 2.8.1
Maven · org.apache.kafka:kafka_2.13introduced 2.4.0, fixed 2.6.3
Maven · org.apache.kafka:kafka_2.13introduced 2.7.0, fixed 2.7.2
Maven · org.apache.kafka:kafka_2.13introduced 2.8.0, fixed 2.8.1
Maven · org.apache.kafka:kafka-clientsintroduced 2.0.0, fixed 2.6.3
Maven · org.apache.kafka:kafka-clientsintroduced 2.7.0, fixed 2.7.2
Maven · org.apache.kafka:kafka-clientsintroduced 2.8.0, fixed 2.8.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database