GHSA-3gx6-h57h-rm27

Drupal Core Remote Code Execution Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2019-6340
Alias
DRUPAL-CORE-2019-003
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H

Description

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.6.0, fixed 8.6.10
Packagist · drupal/coreintroduced 7.0.0, fixed 7.62.0
Packagist · drupal/coreintroduced 8.0.0, fixed 8.5.11
Packagist · drupal/drupalintroduced 7.0.0, fixed 7.62.0
Packagist · drupal/drupalintroduced 8.0.0, fixed 8.5.11
Packagist · drupal/drupalintroduced 8.6.0, fixed 8.6.10

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database