GHSA-3gp6-hhfw-4gqx
Padding oracle attacks
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2010-3300
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.owasp.esapi:esapi | introduced 0, fixed 2.0GA |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2010-3300 ADVISORY
- https://seclists.org/oss-sec/2010/q3/357 WEB
- https://www.usenix.org/legacy/events/woot10/tech/full_papers/Rizzo.pdf WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |