GHSA-3f95-r44v-8mrg

Command injection in simple-git

En bref

Publiée
Mise à jour
CVE
CVE-2022-24433
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

The package simple-git before 3.3.0 is vulnerable to Command Injection via argument injection. When calling the .fetch(remote, branch, handlerFn) function, both the remote and branch parameters are passed to the git fetch subcommand. By injecting some git options, it was possible to get arbitrary command execution.

Paquets affectés

PaquetVersions
npm · simple-gitintroduced 0, fixed 3.3.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database