GHSA-3f5c-4qxj-vmpf

Next.js Directory Traversal Vulnerability

At a glance

Published
Updated
CVE
CVE-2017-16877
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Next.js before 2.4.1 has directory traversal under the `/_next` and `/static` request namespace, allowing attackers to obtain sensitive information.

Affected packages

PackageVersions
npm · nextintroduced 1.0.0, fixed 2.4.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database