GHSA-3cqr-58rm-57f8

Arbitrary Code Execution in Handlebars

En bref

Publiée
Mise à jour
CVE
CVE-2019-20920
Alias
SNYK-JS-HANDLEBARS-534478
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L

Description

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).

Paquets affectés

PaquetVersions
npm · handlebarsintroduced 0, fixed 3.0.8
npm · handlebarsintroduced 4.0.0, fixed 4.5.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database