GHSA-39rw-4m66-82gf

Magento incorrect user permissions vulnerability within the Inventory component

At a glance

Published
Updated
CVE
CVE-2020-24403
Aliases
BIT-magento-2020-24403
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Description

Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect user permissions vulnerability within the Inventory component. This vulnerability could be abused by authenticated users with Inventory and Source permissions to make unauthorized changes to inventory source data via the REST API.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 0, fixed 2.3.6
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.1
Packagist · magento/project-community-editionintroduced 0, last affected 2.0.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database