GHSA-39g6-x4x8-5jcm

Drupal Core Potential Cross-Site Scripting (XSS) via Error Messages

At a glance

Published
Updated
CVE
CVE-2025-3057
Aliases
BIT-drupal-2025-3057, DRUPAL-CORE-2025-001
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 8.0.0, fixed 10.3.13
Packagist · drupal/coreintroduced 10.4.0, fixed 10.4.3
Packagist · drupal/coreintroduced 11.0.0, fixed 11.0.12
Packagist · drupal/coreintroduced 11.1.0, fixed 11.1.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database