GHSA-39ch-rg26-gmq5

Magento DOM-based Cross-Site Scripting vulnerability on mage-messages cookies

En bref

Publiée
Mise à jour
CVE
CVE-2021-28556
Alias
BIT-magento-2021-28556
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N

Description

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.

Paquets affectés

PaquetVersions
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.2-p1
Packagist · magento/community-editionintroduced 0, fixed 2.3.7
Packagist · magento/project-community-editionintroduced 0, last affected 2.0.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database