GHSA-394c-5j6w-4xmx

ua-parser-js Regular Expression Denial of Service vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2020-7793
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

The package ua-parser-js before 0.7.23 are vulnerable to Regular Expression Denial of Service (ReDoS) in multiple regexes (see linked commit for more info).

Paquets affectés

PaquetVersions
npm · ua-parser-jsintroduced 0, fixed 0.7.23

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database