GHSA-33c5-9fx5-fvjm

Privilege Escalation in Kubernetes

En bref

Publiée
Mise à jour
CVE
CVE-2020-8559
Alias
GO-2024-2748
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Description

The Kubernetes kube-apiserver in versions v1.6-v1.15, and versions prior to v1.16.13, v1.17.9 and v1.18.7 are vulnerable to an unvalidated redirect on proxied upgrade requests that could allow an attacker to escalate privileges from a node compromise to a full cluster compromise.

Paquets affectés

PaquetVersions
Go · k8s.io/apimachineryintroduced 0, fixed 0.16.13
Go · k8s.io/apimachineryintroduced 0.17.0, fixed 0.17.9
Go · k8s.io/apimachineryintroduced 0.18.0, fixed 0.18.7
Go · k8s.io/kubernetesintroduced 0, fixed 1.16.13
Go · k8s.io/kubernetesintroduced 1.17.0, fixed 1.17.9
Go · k8s.io/kubernetesintroduced 1.18.0, fixed 1.18.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database