GHSA-3393-hvrj-w7v3
Denial of Service in Elasticsearch
At a glance
- Published
- Updated
- CVE
- CVE-2021-22144
- Aliases
- BIT-elasticsearch-2021-22144
- CVSS_V3
- CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Description
In Elasticsearch versions before 7.13.3 and 6.8.17 an uncontrolled recursion vulnerability that could lead to a denial of service attack was identified in the Elasticsearch Grok parser. A user with the ability to submit arbitrary queries to Elasticsearch could create a malicious Grok query that will crash the Elasticsearch node.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.elasticsearch:elasticsearch | introduced 0, fixed 6.8.17 |
| Maven · org.elasticsearch:elasticsearch | introduced 7.0.0-alpha1, fixed 7.13.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-22144 ADVISORY
- https://discuss.elastic.co/t/elasticsearch-7-13-3-and-6-8-17-security-update/278100 WEB
- https://security.netapp.com/advisory/ntap-20210827-0006 WEB
- https://www.oracle.com/security-alerts/cpuapr2022.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |