GHSA-337m-mw94-2v6g
Apache Commons Configuration: StackOverflowError for YAML input with cycles
At a glance
- Published
- Updated
- CVE
- CVE-2026-45205
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Description
Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.commons:commons-configuration2 | introduced 2.2, fixed 2.15.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-45205 ADVISORY
- https://github.com/apache/commons-configuration/pull/634 WEB
- https://github.com/apache/commons-configuration PACKAGE
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk WEB
- http://www.openwall.com/lists/oss-security/2026/05/14/5 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |