GHSA-3327-jr93-7hq3
Drupal access bypass vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2017-6930
- CVSS_V3
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().
Affected packages
| Package | Versions |
|---|---|
| Packagist · drupal/core | introduced 8.4.0, fixed 8.4.5 |
| Packagist · drupal/drupal | introduced 8.4.0, fixed 8.4.5 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6930 ADVISORY
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6930.yaml WEB
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6930.yaml WEB
- https://github.com/drupal/core PACKAGE
- https://www.drupal.org/sa-core-2018-001 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |