GHSA-32wr-qqw6-5mfp

Apache Airflow vulnerable to sensitive information exposure

At a glance

Published
Updated
CVE
CVE-2023-42663
Aliases
BIT-airflow-2023-42663, PYSEC-2023-197
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow, versions before 2.7.2, has a vulnerability that allows an authorized user with access to read specific DAGs _only_ to read information about task instances in other DAGs. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.7.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database