GHSA-2x6r-7427-95cm
Deserialization of Untrusted Data in Apache Camel RabbitMQ
At a glance
- Published
- Updated
- CVE
- CVE-2020-11972
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Apache Camel RabbitMQ enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.camel:camel-rabbitmq | introduced 0, fixed 2.25.1 |
| Maven · org.apache.camel:camel-rabbitmq | introduced 3.0.0, fixed 3.2.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-11972 ADVISORY
- https://camel.apache.org/security/CVE-2020-11972.html WEB
- https://www.oracle.com/security-alerts/cpujan2021.html WEB
- https://www.oracle.com/security-alerts/cpuoct2020.html WEB
- http://www.openwall.com/lists/oss-security/2020/05/14/10 WEB
- http://www.openwall.com/lists/oss-security/2020/05/14/8 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |