GHSA-2rrx-pphc-qfv9

pgAdmin 4 Vulnerable to Cross-Site Scripting (XSS) via Query Result Rendering

En bref

Publiée
Mise à jour
CVE
CVE-2025-2946
Alias
PYSEC-2026-449
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H

Description

pgAdmin <= 9.1 is affected by a security vulnerability with Cross-Site Scripting(XSS). If attackers execute any arbitrary HTML/JavaScript in a user's browser through query result rendering, then HTML/JavaScript runs on the browser.

Paquets affectés

PaquetVersions
PyPI · pgadmin4introduced 0, fixed 9.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database