GHSA-2pp9-r4rv-6p6j
Exposure of Sensitive Information to an Unauthorized Actor in Jenkins
At a glance
- Published
- Updated
- CVE
- CVE-2018-1999006
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Description
A exposure of sensitive information vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in Plugin.java that allows attackers to determine the date and time when a plugin HPI/JPI file was last extracted, which typically is the date of the most recent installation/upgrade.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.121.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.122, fixed 2.132 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1999006 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/f46842c7a2c916170ac457a039a2f7f019afd885 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-925 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |