GHSA-2p3x-qw9c-25hh

XStream can cause a Denial of Service.

En bref

Publiée
Mise à jour
CVE
CVE-2021-21341
Alias
BIT-activemq-2021-21341
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

### Impact The vulnerability may allow a remote attacker to allocate 100% CPU time on the target system depending on CPU type or parallel execution of such a payload resulting in a denial of service only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. ### Patches If you rely on XStream's default blacklist of the [Security Framework](https://x-stream.github.io/security.html#framework), you will have to use at least version 1.4.16. ### Workarounds See [workarounds](https://x-stream.github.io/security.html#workaround) for the different versions covering all CVEs. ### References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for [CVE-2021-21341](https://x-stream.github.io/CVE-2021-21341.html). ### Credits The vulnerability was discovered and reported by threedr3am. ### For more information If you have any questions or comments about this advisory: * Open an issue in [XStream](https://github.com/x-stream/xstream/issues) * Contact us at [XStream Google Group](https://groups.google.com/group/xstream-user)

Paquets affectés

PaquetVersions
Maven · com.thoughtworks.xstream:xstreamintroduced 0, fixed 1.4.16

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database