GHSA-2mvc-557g-5638
pgAdmin is affected by a multi-factor authentication bypass vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2024-4215
- Aliases
- PYSEC-2026-1768
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L
Description
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
Affected packages
| Package | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 8.6 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-4215 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/7425 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/f4761f55f7cf6d56d6c5129f921393b0b47fd976 WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |