GHSA-2jp3-2923-9h52

Apache ActiveMQ Vulnerable to Cross-site Scripting

At a glance

Published
Updated
CVE
CVE-2026-41043
Aliases
BIT-activemq-2026-41043
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.activemq:apache-activemqintroduced 0, fixed 5.19.6
Maven · org.apache.activemq:activemq-allintroduced 0, fixed 5.19.6
Maven · org.apache.activemq:activemq-brokerintroduced 0, fixed 5.19.6
Maven · org.apache.activemq:apache-activemqintroduced 6.0.0, fixed 6.2.5
Maven · org.apache.activemq:activemq-allintroduced 6.0.0, fixed 6.2.5
Maven · org.apache.activemq:activemq-brokerintroduced 6.0.0, fixed 6.2.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database