GHSA-2j39-qcjm-428w

Apache Struts vulnerable to path traversal

At a glance

Published
Updated
CVE
CVE-2023-50164
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.

Affected packages

PackageVersions
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, fixed 2.5.33
Maven · org.apache.struts:struts2-coreintroduced 6.0.0, fixed 6.3.0.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database