GHSA-2c59-37c4-qrx5

Apache Parquet Avro Module Vulnerable to Arbitrary Code Execution

At a glance

Published
Updated
CVE
CVE-2025-30065
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:A

Description

Schema parsing in the parquet-avro module of Apache Parquet 1.15.0 and previous versions allows bad actors to execute arbitrary code Users are recommended to upgrade to version 1.15.1, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.parquet:parquet-avrointroduced 0, fixed 1.15.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database