GHSA-297f-r9w7-w492
Magento Improper input validation vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2022-42344
- Aliases
- BIT-magento-2022-42344
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the `V1/customers/me` endpoint to achieve information exposure and privilege escalation.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 0, fixed 2.3.7-p4 |
| Packagist · magento/community-edition | introduced 2.4.0, fixed 2.4.3-p3 |
| Packagist · magento/community-edition | introduced 2.4.4, fixed 2.4.5 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-42344 ADVISORY
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb22-38.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |