GHSA-25xr-qj8w-c4vf

Apache Tomcat Coyote vulnerable to Denial of Service via excessive HTTP/2 streams

En bref

Publiée
Mise à jour
CVE
CVE-2025-53506
Alias
BIT-tomcat-2025-53506
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-coyoteintroduced 11.0.0-M1, fixed 11.0.9
Maven · org.apache.tomcat:tomcat-coyoteintroduced 10.1.0-M1, fixed 10.1.43
Maven · org.apache.tomcat:tomcat-coyoteintroduced 9.0.0.M1, fixed 9.0.107
Maven · org.apache.tomcat:tomcat-coyoteintroduced 8.5.0, last affected 8.5.100
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 8.5.0, last affected 8.5.100
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.0.M1, fixed 9.0.107
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.0-M1, fixed 10.1.43
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M1, fixed 11.0.9

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database