GHSA-25mp-g6fv-mqxx

Unexpected server crash in Next.js.

At a glance

Published
Updated
CVE
CVE-2021-43803
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue. Note that prior version 0.9.9 package `next` hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions.

Affected packages

PackageVersions
npm · nextintroduced 12.0.0, fixed 12.0.5
npm · nextintroduced 0.9.9, fixed 11.1.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database