DRUPAL-CORE-2026-011

At a glance

Published
Updated
CVE
CVE-2026-15917

Description

Drupal core 11.2 and above integrate the HTMX JavaScript library. Drupal core's XSS filter does not sufficiently sanitize certain HTMX attributes, which can lead to a cross-site scripting (XSS) vulnerability. The vulnerability is mitigated by the fact an attacker must be able to insert HTML with specific attributes.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 11.3.0, fixed 11.3.14 ; introduced 11.4.0, fixed 11.4.4 ; introduced 11.2.0, fixed 11.3.0

References

Sources

SourceLicence
OSV.devSee osv.dev/data for this database's licence